Le forum du Master ESA économétrie et statistique appliquée - Université d'Orléans

Vous n'êtes pas identifié.

Annonce

Vous êtes sur le forum du master ESA !

Le site du master ESA - description de la formation, notes de cours, contacts... est ici :

http://www.univ-orleans.fr/deg/masters/ESA/

#1 18-10-2007 12:29:00

esa_sr
Administrator
Date d'inscription: 21-02-2007
Messages: 5513
Site web

ODS graphics ne fonctionne pas ? la solution !

donc, des M2 viennent de passer dans mon bureau en me disant : quand je lance un ODS graphics, je n'ai rien qui sort - les graphiques ne sont pas produits.

Déjà, pour voir si ODS graphics fonctionne :

Code:

data toto;
do i=1 to 100;
x=ranuni(123);
y=rannor(214);
output;
end;
run;

ods html;
ods graphics on;
proc reg ;
model y=x;
run;
ods graphics off;
ods html close;

et si dans la fenêtre DIALOGUE, vous avez un message du genre :

Code:

    Can't load class com/sas/tk/util/SetStandardOut.
       Can't redirect System.err to SAS log.
 
     Can't load class com/sas/tk/util/SetStandardOut.
     Can't redirect System.out to SAS log.
 
     Can't load class com/sas/tk/util/SetStandardOut.
     System.out not restored
     Can't load class com/sas/tk/util/SetStandardOut.
     System.err not restored
     ERROR: Java class generated an exception.

la solution est là :

http://support.sas.com/techsup/unotes/S … 15237.html

(il suffit de désinstaller les JAVA RUNTIME ENV. qui n'ont pas été installés avec SAS)

cordialement

SR

Hors ligne

 

Pied de page des forums

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson